Write a class called Marks with a required constructor. Then perform the addition using operator overloading Sample Input 1: Quiz 1 (out of 10): 10 Quiz 2 (out of 10): 10 Lab (out of 30): 30 Mid (out of 20): 20 Final (out of 30): 30 #Write your code here #Do not change the following lines of code Q1 = Marks(int(input("Quiz 1 (out of 10): "))) Q2 = Marks(int(input("Quiz 2 (out of 10): "))) Lab = Marks(int(input("Lab (out of 30): "))) Mid = Marks(int(input("Mid (out of 20): "))) Final = Marks(int(input("Final (out of 30): "))) total = Q1 + Q2 + Lab + Mid + Final Sample Output 1: Total marks: 100 print("Total marks: {}".format(total.mark)) Sample Input 2: Quiz 1 (out of 10): 10 Quiz 2 (out of 10): 8 Lab (out of 30): 30 Mid (out of 20): 20 Final (out of 30): 29 Sample Output 2: Total marks: 97

Computer Networking: A Top-Down Approach (7th Edition)
7th Edition
ISBN:9780133594140
Author:James Kurose, Keith Ross
Publisher:James Kurose, Keith Ross
Chapter1: Computer Networks And The Internet
Section: Chapter Questions
Problem R1RQ: What is the difference between a host and an end system? List several different types of end...
icon
Related questions
Question
Write a class called Marks with a required constructor. Then perform the addition using
operator overloading
Sample Input 1:
Quiz 1 (out of 10): 10
Quiz 2 (out of 10): 10
Lab (out of 30): 30
Mid (out of 20): 20
Final (out of 30): 30
#Write your code here
#Do not change the following lines of code
Q1 = Marks(int(input("Quiz 1 (out of 10): ")))
Q2 = Marks(int(input("Quiz 2 (out of 10): ")))
Lab = Marks(int(input("Lab (out of 30): ")))
Mid = Marks(int(input("Mid (out of 20): ")))
Final = Marks(int(input("Final (out of 30): ")))
total = Q1 + Q2 + Lab + Mid + Final
print("Total marks: {}".format(total.mark))
%D
%3D
%3D
Sample Output 1:
Total marks: 100
%3D
%3D
Sample Input 2:
Quiz 1 (out of 10): 10
Quiz 2 (out of 10): 8
Lab (out of 30): 30
Mid (out of 20): 20
Final (out of 30): 29
Sample Output 2:
Total marks: 97
Transcribed Image Text:Write a class called Marks with a required constructor. Then perform the addition using operator overloading Sample Input 1: Quiz 1 (out of 10): 10 Quiz 2 (out of 10): 10 Lab (out of 30): 30 Mid (out of 20): 20 Final (out of 30): 30 #Write your code here #Do not change the following lines of code Q1 = Marks(int(input("Quiz 1 (out of 10): "))) Q2 = Marks(int(input("Quiz 2 (out of 10): "))) Lab = Marks(int(input("Lab (out of 30): "))) Mid = Marks(int(input("Mid (out of 20): "))) Final = Marks(int(input("Final (out of 30): "))) total = Q1 + Q2 + Lab + Mid + Final print("Total marks: {}".format(total.mark)) %D %3D %3D Sample Output 1: Total marks: 100 %3D %3D Sample Input 2: Quiz 1 (out of 10): 10 Quiz 2 (out of 10): 8 Lab (out of 30): 30 Mid (out of 20): 20 Final (out of 30): 29 Sample Output 2: Total marks: 97
Expert Solution
steps

Step by step

Solved in 4 steps with 3 images

Blurred answer
Recommended textbooks for you
Computer Networking: A Top-Down Approach (7th Edi…
Computer Networking: A Top-Down Approach (7th Edi…
Computer Engineering
ISBN:
9780133594140
Author:
James Kurose, Keith Ross
Publisher:
PEARSON
Computer Organization and Design MIPS Edition, Fi…
Computer Organization and Design MIPS Edition, Fi…
Computer Engineering
ISBN:
9780124077263
Author:
David A. Patterson, John L. Hennessy
Publisher:
Elsevier Science
Network+ Guide to Networks (MindTap Course List)
Network+ Guide to Networks (MindTap Course List)
Computer Engineering
ISBN:
9781337569330
Author:
Jill West, Tamara Dean, Jean Andrews
Publisher:
Cengage Learning
Concepts of Database Management
Concepts of Database Management
Computer Engineering
ISBN:
9781337093422
Author:
Joy L. Starks, Philip J. Pratt, Mary Z. Last
Publisher:
Cengage Learning
Prelude to Programming
Prelude to Programming
Computer Engineering
ISBN:
9780133750423
Author:
VENIT, Stewart
Publisher:
Pearson Education
Sc Business Data Communications and Networking, T…
Sc Business Data Communications and Networking, T…
Computer Engineering
ISBN:
9781119368830
Author:
FITZGERALD
Publisher:
WILEY